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Introduction 

The URL for this guide is below. As we update this guide, the URL will remain the same. 
(You may want to bookmark this link in your web browser.) 

https://softchalk.atlassian.net/wiki/download/attachments/129237016/quickstartguide.pdf?
api=v2  

 

 

SoftChalk Cloud is the fastest, easiest, most flexible way to create, manage and share your 
digital curriculum content for delivery inside or outside of a Learning Management System 
(LMS).  Using SoftChalk Create, our award-winning content authoring software in SoftChalk 
Cloud, you can create engaging, interactive, media-rich learning content with ease.   

Using this guide, you’ll learn how to quickly create a lesson in your SoftChalk Cloud account 
and then put a link of your lesson into your LMS. Depending on the setup of your LMS, you 
may even be able to capture student scores from your lessons into your LMS gradebook 
using a feature called LTI (see Step 5 in this guide for details). 

Your students will be viewing your lesson in a web browser (all the major browsers are 
supported – e.g. Chrome, Edge, Firefox, Internet Explorer and Safari).  

(If you don’t have an LMS, you can still distribute a hyperlink of your lesson or use the 
ScoreCenter feature within your Cloud account to collect scores.) 

After using this guide, you can get additional instructions on getting started, from our Video 
Tutorials, and SoftChalk Cloud Guide and the Getting Started section in our SoftChalk 
Create Guide 

Below are the sections in this guide: 

Step 1 - Create a SoftChalk Cloud Account 

Step 2 - Install SoftChalk Create 

Step 3 - Create Your First SoftChalk Lesson 

Step 4 - Put a Hyperlink of Your Lesson into Your Learning Management System 

Step 5 - Put an LTI Link of Your Lesson into Your Learning Management System 

Learning Management Systems 

Other Resources and Guides 

https://softchalk.atlassian.net/wiki/download/attachments/129237016/quickstartguide.pdf?api=v2
https://softchalk.atlassian.net/wiki/download/attachments/129237016/quickstartguide.pdf?api=v2
https://softchalkcloud.com/
http://softchalk.com/learn-more/training/video-tutorials
http://softchalk.com/learn-more/training/video-tutorials
http://support.softchalk.com/FileManagement/Download/01a6aedad0e145e6a6267b62647be445
http://support.softchalk.com/FileManagement/Download/980bd45c66154772b957a68616b25f1f
http://support.softchalk.com/FileManagement/Download/980bd45c66154772b957a68616b25f1f
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Step 1 - Create a SoftChalk Cloud Account 

If you haven’t already created a SoftChalk Cloud account, please use the steps below to 
create an account. 

IMPORTANT: If your institution has an Enterprise SoftChalk Cloud, you will need a 
different SoftChalk Cloud URL and may need different steps to create a SoftChalk Cloud 
account - please consult your institution’s technical support. 

1. Go to the SoftChalk Cloud website (https://softchalkcloud.com). At the top right, 
click Join Now. 

 

2. For the Account Type, click on the drop down menu and choose SoftChalk CLOUD 
(I have an activation key) and paste in the key provided to you by your 
institution. 

 

3. Fill in the rest of your profile, select the two checkboxes at the bottom and click 
Join.  
 
Congratulations, you now have a SoftChalk Cloud account!  
 
Please see Step 2 – Install SoftChalk Create. 

https://softchalkcloud.com/
https://softchalkcloud.com/
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Step 2 - Install SoftChalk Create 

Even if you are not an administrator on your computer, you may still install SoftChalk 
Create. If you have any questions about computer requirements, please see our System 
Specifications page. If you should happen to run into any issues with your installation, 
please see our FAQs – at the left toward the bottom you’ll see the Installation section. If 
you have a Macintosh, please see the section Macintosh on the next page. 

Windows 

Please note, that you need to have Java installed on your computer. Surface Pro Users – 
Please see our FAQ Can I use my Surface Pro with SoftChalk Create?  

1. Make sure you are logged into https://softchalkcloud.com. The login link is at the 
upper right corner. 

2. Select My Content and then Create Content. 

 

3. The first time you select this option, you will be asked to download an installer to 
your computer. Select the installer for Windows. Please be patient while the 
installer downloads which typically takes two to five minutes.  

4. Open the folder where you downloaded your installer file. Typically, this folder is 
called Downloads on a Windows computer. The installer file is called SoftChalk-
Create-Cloud-10.03.00.exe. Double-click on this file to run the installation.  
For the single user profile installation, the application will be installed in 
C:\Users\USERNAME\AppData\Local\SoftChalk\Create. (If you are an admin 
installing for all users, the location would be C:\Program Files\SoftChalk\Create.) 

5. Once you have installed Create you will see a blue SoftChalk Create icon on your 
desktop (see below).  
 
If you run into problems installing, you may have an issue with Java on your 
computer. Please see the FAQ How do I tell if I have Java installed successfully on 
my Windows computer? 

 

Please see Step 3 - Create Your First SoftChalk Lesson. 

http://softchalk.com/products/system-specifications
http://softchalk.com/products/system-specifications
http://support.softchalk.com/ics/support/default.asp?deptID=15143
http://support.softchalk.com/ics/support/kbanswer.asp?deptID=15143&task=knowledge&questionID=1778&languageID=
https://softchalkcloud.com/
http://support.softchalk.com/ics/support/default.asp?deptID=15143&task=knowledge&questionID=1791&languageID=
http://support.softchalk.com/ics/support/default.asp?deptID=15143&task=knowledge&questionID=1791&languageID=
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Macintosh 

1. Make sure you are logged into https://softchalkcloud.com. The login link is in the 
upper right corner. 

2. Select My Content and then Create Content. 

 

3. The first time you select this option, you will be asked to download an installer to 
your computer. Select the installer for Macintosh. Please be patient while the 
installer downloads which typically takes two to five minutes. Click Open. 

  

4. On your desktop, double-click on the SoftChalk-Create.dmg file (see below). 

 

5. Double-click on the SoftChalk Installer icon (see below) and proceed to the next step 
on the following page. 

 

If you do NOT see the SoftChalk Installer icon above on your desktop, then see the 
following solutions: 

a. Please open your computer icon, typically Macintosh HD. Then look at the 
left hand column under Devices, and click on SoftChalk Installer and 
continue with Step 6 below.  

https://softchalkcloud.com/
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b. If you do NOT see the SoftChalk Installer icon under the Devices area, then 
you may be using a non-standard program to open .dmg files. Control-click 
on the SoftChalk-Create.dmg file. Choose Open with and make sure that 
DiskImageMounter.app is the selected application. 

6. You’ll see the SoftChalk.app and the Applications folder (see below).  
 
IMPORTANT: You must either drag the SoftChalk.app onto your desktop or drag it 
into your Applications folder. Be sure to close your SoftChalk Installer window. 

 
 

7. Open your Applications folder. Double-click on SoftChalk within your Applications 
folder (see below) or on your desktop (NOT within the SoftChalk Installer area shown 
previously). 

 

8. Click Open at the screen asking if you want to open this application downloaded 
from the Internet (see below). Please see Step 3 - Create Your First SoftChalk 
Lesson. 
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Step 3 - Create Your First SoftChalk Lesson 

Below are instructions on creating a simple three page lesson with a question, an activity 
and an embedded YouTube video. 

Start SoftChalk Create 

1. Once you have installed Create successfully (see the previous section Step 2 – Install 
SoftChalk Create), you will see a blue SoftChalk Create icon on your desktop (see 
below). Double-click on this icon. (The Macintosh icon will say SoftChalk.) 

 

2. Enter your SoftChalk Cloud username and password and click Register. (If your 
institution has an Enterprise SoftChalk Cloud, then select the option My account is 
with a Enterprise Cloud and enter the appropriate URL that you have gotten from 
your institution’s technical support.) 

Add a Style 

1. Go to the Properties menu at the top and select Style Properties. 

2. At the right select a style and click OK. (At any point you can change this style.) 
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Add a Question – Ex. Multiple Choice 

1. Hit your Enter or Return key to create a new paragraph. 

2. Go to the Insert menu at the top and select QuizPopper / Multiple Choice. Please 
note there are a variety of questions that you can insert besides Multiple Choice. 

3. Type in a question. At the bottom, enter 40 for the points. 

 

4. Click the Answers tab. Enter your answers and individual feedback (optional). To 
add another answer, click Add Answer. In the correct column at the left, select the 
correct answer. 
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5. Click the Display tab at the top. Notice you have three options for how the question 
will be viewed by the student. The default is Embed in lesson page. Click OK. 

6. If you left the default display setting for the Multiple Choice question as embed in 
lesson page, you will see a gray placeholder box. (To edit the question you just 
created, you can right click on this box and choose Modify QuizPopper.) 

Add a Page Break 

1. In the main editing window, hit your Enter or Return key to create a new paragraph. 

2. Go to the Insert menu at the top and select Page Break / Insert. 

Add an Activity – Ex. Ordering 

1. Go to the Insert menu at the top and select Activity / Ordering. Please note there 
are a variety of activities that you can insert besides the Ordering activity. 

2. Please note the How To tab, which is available on all activities. You can view an 
example of the activity and a short video on how to create the activity.  

3. Let’s say you want to have students order the first eight planets based on proximity 
to the sun. In the Item area, type Mercury. Then click Add to List. 
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4. In the Item area, type Venus. Then click Add to List. 

 

5. Continue adding the other planets. 
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6. Click on the Options tab. At the top in the Instructions for the student, you can 
modify the instructions for your specific activity.   
 
For the Activity Display, you can choose Pop-up from icon.  
 
At bottom right, choose 80 for the points.  
 
Click OK. 

 

7. In the main editing window, hit your Enter or Return key to create a new paragraph. 

8. Go to the Insert menu at the top and select Page Break / Insert. 
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Embed a YouTube Video 

Using the steps below, you’ll embed the code for a YouTube video within your lesson.  

1. Go to the Tools menu at the top and select Media Search. 

2. In the list at the left, scroll down and select YouTube and click I agree. 

3. At the top, type in a keyword such as algebra and click Search. 

4. From the results list at the right, select an item and click Insert. Click OK at the 
Insert complete window. Click Close to return to your main editing window. 

 

5. In your main editing window, you will see a gray placeholder box for your widget 
(i.e. YouTube video code). To edit the change the YouTube you just created, you can 
right click on this box and choose Modify Widget.) 

Save Your Lesson to SoftChalk Cloud 

1. Go to the File menu at the top and select Save to SoftChalk Cloud. (If you happen 
to click the Save icon rather than choosing File / Save to SoftChalk Cloud, you 
would be saving your lesson temporarily on your local computer. You will be 
prompted to save to your lesson permanently before you exit the Create program.) 

2. Type an item name and click Save. 

3. Click Close to leave the Save window. Congratulations you have created your first 
SoftChalk lesson! 

4. To exit the Create program, choose File / Exit. 
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Preview Your Lesson in a Web Browser 

You can log into your Cloud account and preview your lesson or you can preview you lesson 
from your SoftChalk Create program. 

Preview Your Lesson from within Your Cloud Account 

1. Log into https://softchalkcloud.com. The login link is in the upper right corner. 

2. Select My Content and then Lessons.  

3. Click on the name of your lesson. 

4. Click the Preview link. 

Preview Your Lesson from within the Create Program 

1. Start your SoftChalk Create program if it is not open already. 

 

2. Open you lesson if it is not open already (choose File / Open from SoftChalk 
Cloud). Selet you lesson and click Open. 

3. From the toolbar at the top, click the View in Browser icon. 

 

 

https://softchalkcloud.com/
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Edit Your Lesson 

Below are several methods to edit your lesson that was saved to SoftChalk Cloud: 

Start Create from Your Desktop Icon: 

1. From your computer desktop, double-click on the blue SoftChalk Create icon to start 
the program.  

2. Go to the File menu at the top and select Open from SoftChalk Cloud. 

3. Select the lesson you want to edit and click Open. 

4. After you make your edits and then choose File / Save to SoftChalk Cloud, please 
make sure that your lesson is selected at the right to be replaced. 

Start Create from Your SoftChalk Cloud Account 

1. Log into https://softchalkcloud.com. The login link is in the upper right corner. 

2. Select My Content and then Lessons.  

3. Click on the name of your lesson. 

4. Scroll down to the Lesson Actions area on the right and select Edit Lesson. 

• The first option, Edit in Create, will launch the same program you used 
previously. After you make your edits and then choose File / Save to 
SoftChalk Cloud, please make sure that your lesson is selected at the right 
to be replaced. 

• The second option, Edit in Create Online, will launch the Create Online 
browser program that allows you to make quick edits to your text. You can 
also enter text as well. Over time, SoftChalk plans to make more and more 
features available in this browser version of SoftChalk Create. Make your edits 
and then click the Save icon. 

The next sections will cover the steps for putting links to your lessons into your learning 
management system.  

• If you don’t need to collect scores from your lesson, then see the section Step 4 – 
Put a Hyperlink of Your Lesson into Your Learning Management System. 

• If you want to collect student scores from your lesson in your LMS gradebook, then 
then see the section Step 5 – Put an LTI Link of Your Lesson into Your Learning 
Management System.  

If you do NOT have an LMS and want to collect scores, please see the section Track 
Student Scores OUTSIDE an LMS (ScoreCenter) in the SoftChalk Cloud Guide.  

https://softchalkcloud.com/
http://support.softchalk.com/FileManagement/Download/01a6aedad0e145e6a6267b62647be445
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Step 4 - Put a Hyperlink of Your Lesson into Your Learning 
Management System 

If you want to use your SoftChalk lesson as a “practice” lesson for your students, below are 
instructions for finding the hyperlink for your lesson, which you can put into your LMS (or 
give to your students via email if you don’t have an LMS). 

1. Log into https://softchalkcloud.com. The login link is in the upper right corner. 

 

2. Select My Content / Lessons. 

  

3. Click on the name of your lesson. 

 

4. Scroll down to the Lesson Actions area. At the bottom right, right-click within the 
Hyperlink field and choose Copy (see below) 

 

5. See the section Learning Management Systems for information on putting this link 
into your LMS. You can view a Non Scored Lesson video or follow a guide for 
instructions - see the section Non Scored Lessons in the Guide for your particular 
Learning Management System. 

https://softchalkcloud.com/
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Step 5 - Put an LTI Link of Your Lesson into Your Learning 
Management System 

Your Learning Management System gradebook may be able to accept scores from SoftChalk 
lessons using a feature called LTI. Please contact your institution’s technical support to see 
if LTI has been enabled. If it has, please see the steps below. 

1. Log into https://softchalkcloud.com. The login link is in the upper right corner. 

1. Select My Content / Lessons. 

 

2. Click on the name of your lesson. 

 

3. Scroll down to the Lesson Actions area. At the bottom right, right-click within the 
LTI Link field and choose Copy (see below) 

 

4. See the section Learning Management Systems for information on putting this link 
into your LMS. You can view a Scored Lesson video or follow a guide for 
instructions - see the section Scored Lessons in the Guide for your particular 
Learning Management System. 

https://softchalkcloud.com/
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Learning Management Systems 

As mentioned previously, in order to use the scored lesson feature shown in the Scored 
Lesson Videos below, your LMS administrator needs to enable the LTI feature in your LMS. 
Instructions for the LMS administrator for enabling this LTI feature are found in the guides 
below. Typically, this process takes thirty minutes for the LMS administrator. 

Please contact your institution’s technical support to see if the LTI feature has been 
enabled. 

 

LMS Videos Guide 

Blackboard Non Scored Lesson 

Scored Lesson 

Blackboard and SoftChalk Cloud 
Integration Guide 

BrainHoney Non Scored Lesson 

Scored Lesson 

BrainHoney 

BrightSpace 
by D2L 

Non Scored Lesson 

Scored Lesson 

BrightSpace by D2L 

Canvas Non Scored Lesson 

Scored Lesson 

Canvas (Instructure) 

Jenzabar  Jenzabar eLearning 

Moodle Non Scored Lesson 

Scored Lesson 

Moodle 

Schoology Scored Lesson Schoology 

 
 
 

For additional resources and guides, please see the next section Other Resources and 
Guides. 

http://softchalk.com/video-tutorials/publishing-lessons/publish-to-blackboard/placing-a-softchalk-cloud-lesson-to-blackboard-as-a-non-scored-lesson/
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-blackboard/softchalk-cloud-lesson-to-blackboard-service-pack-10-or-greater-lti-weblink/
http://support.softchalk.com/FileManagement/Download/1d8dded15c3747cb817ff8868ce612d5
http://support.softchalk.com/FileManagement/Download/1d8dded15c3747cb817ff8868ce612d5
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-brainhoney/adding-non-scored-lessons-into-brainhoney/
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-brainhoney/adding-scored-activities-into-brainhoney/
http://support.softchalk.com/FileManagement/Download/9f174df7223d41609a78093ad9217683
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-desire2learn/placing-a-softchalk-cloud-lesson-in-desire2learn-using-hyperlink/
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-desire2learn/placing-a-softchalk-cloud-lesson-with-score-center-into-desire2learn/
http://support.softchalk.com/FileManagement/Download/905f3fd4afea45cb9559d359f12a2cd8
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-canvas/softchalk-cloud-lessons-placed-in-canvas-as-a-non-scored-item/
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-canvas/placing-a-softchalk-cloud-lesson-into-canvas-using-learning-interoperability-link/
http://support.softchalk.com/FileManagement/Download/e3265a4581394ac0b980d772a97983f7
http://support.softchalk.com/FileManagement/Download/ac08e1dfbc874ae28c0f939617b29f6b
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-moodle/placing-a-softchalk-cloud-lesson-into-moodle-2-2-as-a-non-scored-lesson-using-hyperlink/
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-moodle/placing-a-softchalk-cloud-lesson-into-moodle-2-2-as-a-scored-lesson-using-lti/
http://support.softchalk.com/FileManagement/Download/5eefaab891744e8d93a431433d51ed12
http://softchalk.com/video-tutorials/publishing-lessons/publish-to-schoology/placing-a-scored-lesson-into-schoology/
http://support.softchalk.com/FileManagement/Download/e11ae749bb2e4769abaa51290696b2f4
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Other Resources and Guides 

Resource Description 

Sample Lessons View sample lessons created by SoftChalk customers. 

Video Tutorials The videos are typically 2-5 minutes long and cover 
Getting Started with SoftChalk Cloud as well as saving a 
lesson to SoftChalk Cloud, using images in SoftChalk, 
and creating quizzes and activities. 

SoftChalk Webinars Sign up for free SoftChalk webinars including 
Introductory Webinars for getting started with SoftChalk 
Cloud. 

SoftChalk Cloud Guide Contains info on how to create a Cloud account, 
collaborate on lessons with other instructors, share 
content and find content to use in our SoftChalk Share 
repository. 

SoftChalk Create Guide Gives details on using SoftChalk Create, our award-
winning content authoring software. SoftChalk Create is 
a feature within your SoftChalk Cloud account. 

Student Guide to SoftChalk 
Lessons 

Contains info for students taking SoftChalk lessons. 
Includes a Troubleshooting section.  

Migration to SoftChalk Cloud If you are already familiar with the desktop version of 
SoftChalk Create and want to start using SoftChalk 
Cloud, this is the guide for you. 

PowerPoint Integration Guide Describes options for incorporating PowerPoint content 
into your SoftChalk lessons 

System Specifications Gives the system specifications for both instructors who 
are creating content (e.g. SoftChalk lessons) and 
students who are viewing SoftChalk lessons in web 
browsers. 

FAQs Frequently Asked Questions 

http://softchalk.com/showcase/sample-lessons/
http://softchalk.com/learn-more/training/video-tutorials/
http://softchalk.com/learn-more/webinars/
http://support.softchalk.com/FileManagement/Download/01a6aedad0e145e6a6267b62647be445
http://support.softchalk.com/FileManagement/Download/980bd45c66154772b957a68616b25f1f
http://support.softchalk.com/FileManagement/Download/f63c73ce33fb45f091657ba93a4d92b0
http://support.softchalk.com/FileManagement/Download/f63c73ce33fb45f091657ba93a4d92b0
http://support.softchalk.com/FileManagement/Download/191719d5301e42bca448243ac889ad28
http://support.softchalk.com/FileManagement/Download/f499e808d48f46c396e483ddfc820100
http://softchalk.com/products/system-specifications/
http://support.softchalk.com/
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Help 

Please visit our SoftChalk Support webpage. For purchase information, please contact 
sales@softchalk.com.  

Copyright Information 

SoftChalk Cloud Quick Start Guide 
Copyright 2017 2018 SoftChalk LLC 
All Rights Reserved 

https://softchalk.com/support/
mailto:sales@softchalk.com
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